Agents Deprecation and TLS Upgrade

Agents Deprecation
Longtime Oomnitza users may be familiar with Oomnitza Agents. These Agents were installed on devices to collect system information and aggregate it in Oomnitza. Because of the need for enhanced security and Oomnitza's focus on agentless, connector-based device management, the upcoming upgrade to support TLS 1.2 will prevent existing Oomnitza Agents from communicating with Oomnitza, permanently disabling them. Therefore, we are officially announcing the sunset of Oomnitza Agents.


Please take the following steps to avoid service disruption when agents are deprecated:

  • Check to see if you currently have any agents in use. To do so, look for an "Agents" tab on the settings page. If this tab appears, Agents may still be in use.
  • Find a suitable replacement for those agents. A full list of device integrations can be found here, under devices: https://www.oomnitza.com/product/integrations
  • Configure the Oomnitza Connector to collect data from the external service and load it into Oomnitza. This process is straightforward, and can typically be done in an hour or less.
  • Reach out to support@oomnitza.com with any questions during this process.

TLS Upgrade
Oomnitza plans to align to industry-standard best practices and make infrastructure changes to our support of Transport Layer Security (TLS). Effective January 31, 2020, Oomnitza will only support TLS 1.2 client connections and will refuse connections from all TLS 1.0 and 1.1 clients due to security vulnerabilities.

Modern browsers and operating systems support TLS 1.2. However, if you are using legacy operating systems or browsers, you may need to take action to prevent service disruption. If you take no action when Oomnitza removes support for TLS 1.0 and 1.1, you may partially or completely lose the ability to use the Oomnitza service.

Further Actions Required:

To avoid any disruption to your service, you must complete the following actions for your organization prior to January 31, 2020:

  • Upgrade any old Oomnitza connectors (self-hosted) to the versions which support TLS 1.2. 
  • Ensure all users are using current browsers and latest mobile OS versions.
  • For custom integrations, ensure that all connections to the Oomnitza API are made from software that supports TLS 1.2.


How to Get Help?
If you have any questions, please email support@oomnitza.com.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk